Java JRE(Java Runtime Environment) – インストール

Java Runtimeのインストールについてです。
Javaで書かれた解析ツール(FastQCなど)を使用する場合は、インストールが必要です。尚、FastQC v0.11.4では1.6以上が必要。

インストール

パッケージ管理
# sudo apt-get install default-jre

インストール確認

javaを呼び出して、バージョンが表示されればインストール完了です。

$ java -version
java version "1.7.0_91"
エラーが発生する場合

* インストール作業に問題なかったのに、「インストールされていない」というエラーが発生する。
“The program ‘application’ is currently not installed. You can install it by typing: sudo apt-get install application”
このような場合は、パスが通っていません。パスを通しましょう。