Cufflinks v2.2.1 – インストール

こんにちは、バイオインフォ道場 biくまぞうです。

Cufflinks v2.2.1をインストールします。プリコンパイル版です。

スポンサーリンク



インストール

マニュアルに従い、プリコンパイル版をインストールします。

場所
# cd /usr/local
DL
# wget http://cole-trapnell-lab.github.io/cufflinks/assets/downloads/cufflinks-2.2.1.Linux_x86_64.tar.gz
展開
# tar xzf cufflinks-2.2.1.Linux_x86_64.tar.gz
Links
# ln -s /usr/local/cufflinks-2.2.1.Linux_x86_64/[cg]* /usr/local/bin/

インストール確認

cufflinksを呼び出して、使い方やオプションが表示されればインストール完了です。

$ cufflinks

エラーが発生する場合

  • インストール作業に問題なかったのに、「インストールされていない」というエラーが発生する。
    “The program ‘application’ is currently not installed. You can install it by typing: sudo apt-get install application”
    このような場合は、パスが通っていません。[パス](command-path)を通しましょう。
  • インストール時に、エラーが発生していたが無視した。
    特に「.」が見落とされがちです。linuxでは「.」にも意味があるので注意しましょう。エラーが発生したところから、やり直して下さい。

参考情報

cufflinks home
cufflinks install(release information)
cufflinks getting_started

スポンサーリンク